Index of /pub/pkgsrc/current/pkgsrc/x11/ruby-gtksourceview3

[ICO]NameLast modifiedSizeDescription

[PARENTDIR]Parent Directory  -  
[   ]DESCR2019-09-15 03:11 199  
[   ]Makefile2020-03-11 10:01 643  
[   ]PLIST2019-09-15 03:11 721  
[TXT]README.html2020-04-02 22:51 30K 
[   ]distinfo2019-10-20 10:01 422  

The NetBSD Packages Collection: x11/ruby-gtksourceview3 Daemon Power

The NetBSD Packages Collection: x11/ruby-gtksourceview3

Brief description of the package:
Ruby binding of gtksourceview3

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://ruby-gnome2.osdn.jp/.

Please note that this package has a gnu-lgpl-v2.1 license.

The package is located in the "x11/ruby-gtksourceview3" directory. The current source version of the package is "ruby26-gtksourceview3-3.4.1nb2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for x11/ruby-gtksourceview3 :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby26-gobject-introspection>=3.4.1 ruby26-glib2>=3.4.1 ruby26-native-package-installer>=1.0.3 ruby26-base>=2.6.6 openssl>=1.1.1 cwrappers>=20150314 libyaml>=0.1.1 openssl>=1.1.1dnb2 libyaml>=0.1.4 ruby26-pkg-config>=1.3.5 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 meson-[0-9]* ninja-build>=1.7 python37>=3.7 libuuid>=2.18 readline>=2.2 readline>=6.0 python37>=3.7.0 re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.7 glib2>=2.64.0nb1 gobject-introspection>=1.32.1 py37-cElementTree-[0-9]* glib2>=2.58.0 libffi>=3.0.0 gobject-introspection>=0.6.14nb1 ruby26-glib2>=3.3.8 gobject-introspection>=1.62.0nb1 ruby26-glib2>=3.4.1nb1 ruby26-gtk3>=3.4.1 ruby26-atk>=3.4.1 atk>=1.11.4 glib2>=2.38.0 atk>=2.33.3nb1 ruby26-gio2>=3.4.1 ruby26-gobject-introspection>=3.3.8 ruby26-gobject-introspection>=3.4.1nb1 ruby26-pango>=3.4.1 ruby26-cairo-gobject>=3.4.1 ruby26-cairo>=1.16.2 ruby26-pkg-config>=1.2.2 cairo>=1.2.0 Xrender>=0.2 x11-links>=1.31 osabi-NetBSD-8.1_STABLE xorgproto>=2016.1 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.14 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 lzo>=2.01 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo>=1.16.0 ruby26-pkg-config-[0-9]* ruby26-cairo>=1.6.0 cairo-gobject>=1.10.2 glib2>=2.14.0 ruby26-cairo>=1.16.2nb1 cairo-gobject>=1.16.0nb4 pango>=1.44.0 Xft2>=2.1.7nb3 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 Xrender>=0.8 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.59 harfbuzz>=2.0 icu>=3.4 graphite2>=1.2 icu>=64.1 harfbuzz>=2.1.1 cairo>=1.12.10 Xft2>=2.1.7nb7 harfbuzz>=2.6.4nb2 pango>=1.6.0 pango>=1.44.7nb2 ruby26-gdk3>=3.4.1 ruby26-gdk_pixbuf2>=3.4.1 gdk-pixbuf2>=2.36.4 shared-mime-info>=0.15 glib2>=2.37.2 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 shared-mime-info>=1.0nb1 tiff>=4.0.3nb5 gdk-pixbuf2>=2.22.0 gdk-pixbuf2>=2.40.0nb1 gtk3+>=3.4.2 atk>=2.15.1 glib2>=2.57.2 gdk-pixbuf2>=2.30.0 at-spi2-atk>=2.6.1 atk>=2.33.3 glib2>=2.32.0 at-spi2-core>=2.33.2 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 perl>=5.0 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 libXtst>=1.0.1 at-spi2-core>=2.3.2 dbus>=1.5 at-spi2-core>=2.35.1nb1 xcursor>=1.0 Xfixes>=2.0.0 fixesproto>=3.0.0<5 Xfixes>=2.0.1nb2 xcursor>=1.1.1 Xft2>=2.1.2nb2 Xrandr>=0.99 Xrandr>=1.0.1 libXcomposite>=0.3.1 pango>=1.41 cairo>=1.14.0 libepoxy>=1.4 MesaLib>=3.4.2 libelf>=0.8.5 libLLVM>=7.0.1nb2 libLLVM>=9.0.0 libvdpau>=0.3 libXdamage>=1.0.3 libxshmfence>=1.2 xorg-util-macros>=1.17 libdrm>=2.4.99 libdrm>=2.4.100 libdrm>=2.4.15 libva>=2.3.0 Xrandr>=1.0.2nb3 MesaLib>=20.0.1nb1 py37-expat>=0 libepoxy>=1.2 hicolor-icon-theme>=0.4 desktop-file-utils>=0.8 at-spi2-atk>=2.34.1nb1 xcursor>=1.1.2nb1 hicolor-icon-theme>=0.9nb1 desktop-file-utils>=0.10nb1 gobject-introspection>=1.39.0 gtk3+>=3.0.0 gtk3+>=3.24.14nb2 ruby26-pango>=3.3.8 ruby26-pango>=3.4.1nb2 gtksourceview3>=3.4.2 glib2>=2.48 gobject-introspection>=1.42.0 gtk3+>=3.20 itstool-[0-9]* py37-libxml2-[0-9]* libxml2>=2.9.10 gtksourceview3>=3.24.11nb2 .

This package requires the following package(s) to run: ruby26-gobject-introspection>=3.4.1 ruby26-glib2>=3.4.1 ruby26-native-package-installer>=1.0.3 ruby26-base>=2.6.6 openssl>=1.1.1 libyaml>=0.1.1 openssl>=1.1.1dnb2 libyaml>=0.1.4 ruby26-pkg-config>=1.3.5 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 glib2>=2.64.0nb1 gobject-introspection>=1.32.1 py37-cElementTree-[0-9]* python37>=3.7 libuuid>=2.18 python37>=3.7.0 python37>=3.7.7 py37-expat-[0-9]* glib2>=2.58.0 libffi>=3.0.0 gobject-introspection>=0.6.14nb1 ruby26-glib2>=3.3.8 gobject-introspection>=1.62.0nb1 ruby26-glib2>=3.4.1nb1 ruby26-gtk3>=3.4.1 ruby26-atk>=3.4.1 atk>=1.11.4 glib2>=2.38.0 atk>=2.33.3nb1 ruby26-gio2>=3.4.1 ruby26-gobject-introspection>=3.3.8 ruby26-gobject-introspection>=3.4.1nb1 ruby26-pango>=3.4.1 ruby26-cairo-gobject>=3.4.1 ruby26-cairo>=1.16.2 ruby26-pkg-config>=1.2.2 cairo>=1.2.0 Xrender>=0.2 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 lzo>=2.01 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo>=1.16.0 ruby26-cairo>=1.6.0 cairo-gobject>=1.10.2 glib2>=2.14.0 ruby26-cairo>=1.16.2nb1 cairo-gobject>=1.16.0nb4 pango>=1.44.0 Xft2>=2.1.7nb3 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 Xrender>=0.8 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.59 harfbuzz>=2.0 icu>=3.4 graphite2>=1.2 icu>=64.1 harfbuzz>=2.1.1 cairo>=1.12.10 Xft2>=2.1.7nb7 harfbuzz>=2.6.4nb2 pango>=1.6.0 pango>=1.44.7nb2 ruby26-gdk3>=3.4.1 ruby26-gdk_pixbuf2>=3.4.1 gdk-pixbuf2>=2.36.4 shared-mime-info>=0.15 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 glib2>=2.37.2 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 shared-mime-info>=1.0nb1 tiff>=4.0.3nb5 gdk-pixbuf2>=2.22.0 gdk-pixbuf2>=2.40.0nb1 gtk3+>=3.4.2 atk>=2.15.1 glib2>=2.57.2 gdk-pixbuf2>=2.30.0 at-spi2-atk>=2.6.1 atk>=2.33.3 glib2>=2.32.0 at-spi2-core>=2.33.2 dbus>=0.91 libXtst>=1.0.1 at-spi2-core>=2.3.2 dbus>=1.5 at-spi2-core>=2.35.1nb1 xcursor>=1.0 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 xcursor>=1.1.1 Xft2>=2.1.2nb2 Xrandr>=0.99 Xrandr>=1.0.1 libXcomposite>=0.3.1 pango>=1.41 cairo>=1.14.0 libepoxy>=1.4 MesaLib>=3.4.2 libelf>=0.8.5 libLLVM>=7.0.1nb2 libLLVM>=9.0.0 libvdpau>=0.3 libXdamage>=1.0.3 libxshmfence>=1.2 libdrm>=2.4.99 libdrm>=2.4.100 libdrm>=2.4.15 libva>=2.3.0 Xrandr>=1.0.2nb3 MesaLib>=20.0.1nb1 libepoxy>=1.2 hicolor-icon-theme>=0.4 desktop-file-utils>=0.8 at-spi2-atk>=2.34.1nb1 xcursor>=1.1.2nb1 hicolor-icon-theme>=0.9nb1 desktop-file-utils>=0.10nb1 gtk3+>=3.0.0 gtk3+>=3.24.14nb2 ruby26-pango>=3.3.8 ruby26-pango>=3.4.1nb2 gtksourceview3>=3.4.2 glib2>=2.48 gobject-introspection>=1.42.0 gtk3+>=3.20 gtksourceview3>=3.24.11nb2 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:

alpha:ruby24-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
alpha:ruby25-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
alpha:ruby26-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
alpha:ruby24-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
alpha:ruby25-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
alpha:ruby26-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
earmv4:ruby24-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
earmv4:ruby25-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
earmv4:ruby26-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
earmv6hf:ruby24-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
earmv6hf:ruby25-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
earmv6hf:ruby26-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
earmv6hf:ruby24-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
earmv6hf:ruby25-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
earmv6hf:ruby26-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
earmv6hf:ruby24-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
earmv6hf:ruby25-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
earmv6hf:ruby26-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
earmv7hf:ruby24-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
earmv7hf:ruby25-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
earmv7hf:ruby26-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
earmv7hf:ruby24-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
earmv7hf:ruby25-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
earmv7hf:ruby26-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
earmv7hf:ruby24-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
earmv7hf:ruby25-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
earmv7hf:ruby26-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
i386:ruby24-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
i386:ruby25-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
i386:ruby26-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
i386:ruby24-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
i386:ruby25-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
i386:ruby26-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
i386:ruby24-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
i386:ruby25-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
i386:ruby26-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
mips64eb:ruby24-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
mips64eb:ruby25-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
mips64eb:ruby26-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
powerpc:ruby24-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
powerpc:ruby25-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
powerpc:ruby26-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
powerpc:ruby24-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
powerpc:ruby25-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
powerpc:ruby26-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
sparc64:ruby24-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
sparc64:ruby25-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
sparc64:ruby26-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
x86_64:ruby24-gtksourceview3-3.4.1nb2.tgz(NetBSD 9.0)
x86_64:ruby25-gtksourceview3-3.4.1nb2.tgz(NetBSD 9.0)
x86_64:ruby26-gtksourceview3-3.4.1nb2.tgz(NetBSD 9.0)
x86_64:ruby27-gtksourceview3-3.4.1nb2.tgz(NetBSD 9.0)
x86_64:ruby24-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
x86_64:ruby25-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
x86_64:ruby26-gtksourceview3-3.4.1.tgz(NetBSD 8.0)
x86_64:ruby24-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
x86_64:ruby25-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
x86_64:ruby26-gtksourceview3-3.3.8.tgz(NetBSD 8.0)
x86_64:ruby24-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
x86_64:ruby25-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
x86_64:ruby26-gtksourceview3-3.4.1.tgz(NetBSD 9.0)
x86_64:ruby24-gtksourceview3-3.4.1nb2.tgz(NetBSD 9.0)
x86_64:ruby25-gtksourceview3-3.4.1nb2.tgz(NetBSD 9.0)
x86_64:ruby26-gtksourceview3-3.4.1nb2.tgz(NetBSD 9.0)
x86_64:ruby27-gtksourceview3-3.4.1nb2.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]