Index of /pub/pkgsrc/current/pkgsrc/x11/py-Xlib

[ICO]NameLast modifiedSizeDescription

[PARENTDIR]Parent Directory  -  
[   ]DESCR2004-08-18 00:30 261  
[   ]Makefile2019-11-04 10:01 664  
[   ]PLIST2019-10-03 10:01 6.6K 
[TXT]README.html2020-04-02 22:52 26K 
[   ]distinfo2019-08-06 10:01 421  

The NetBSD Packages Collection: x11/py-Xlib Daemon Power

The NetBSD Packages Collection: x11/py-Xlib

Brief description of the package:
XLib in pure Python

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/python-xlib/python-xlib/.

Please note that this package has a gnu-lgpl-v2.1 license.

The package is located in the "x11/py-Xlib" directory. The current source version of the package is "py37-Xlib-0.25nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for x11/py-Xlib :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py37-setuptools_scm-[0-9]* py37-toml-[0-9]* py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 cwrappers>=20150314 libuuid>=2.18 openssl>=1.1.1 libffi>=3.3nb1 openssl>=1.1.1dnb2 readline>=2.2 readline>=6.0 python37>=3.7.0 python37>=3.7.7 py37-six-[0-9]* .

This package requires the following package(s) to run: py37-setuptools_scm-[0-9]* py37-toml-[0-9]* py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 libuuid>=2.18 openssl>=1.1.1 libffi>=3.3nb1 openssl>=1.1.1dnb2 python37>=3.7.0 python37>=3.7.7 py37-six-[0-9]* .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:

aarch64:py27-Xlib-0.25nb1.tgz(NetBSD 9.0)
aarch64:py36-Xlib-0.25nb1.tgz(NetBSD 9.0)
aarch64:py37-Xlib-0.25nb1.tgz(NetBSD 9.0)
alpha:py27-Xlib-0.25nb1.tgz(NetBSD 9.0)
alpha:py36-Xlib-0.25nb1.tgz(NetBSD 9.0)
alpha:py37-Xlib-0.25nb1.tgz(NetBSD 9.0)
earm:py27-Xlib-0.14.tgz(NetBSD 7.0)
earm:py33-Xlib-0.14.tgz(NetBSD 7.0)
earm:py34-Xlib-0.14.tgz(NetBSD 7.0)
earm:py35-Xlib-0.14.tgz(NetBSD 7.0)
earm:py27-Xlib-0.14.tgz(NetBSD 8.0)
earm:py34-Xlib-0.14.tgz(NetBSD 8.0)
earm:py35-Xlib-0.14.tgz(NetBSD 8.0)
earm:py36-Xlib-0.14.tgz(NetBSD 8.0)
earm:py37-Xlib-0.14.tgz(NetBSD 8.0)
earmv6hf:py27-Xlib-0.25nb1.tgz(NetBSD 8.0)
earmv6hf:py36-Xlib-0.25nb1.tgz(NetBSD 8.0)
earmv6hf:py37-Xlib-0.25nb1.tgz(NetBSD 8.0)
earmv6hf:py38-Xlib-0.25nb1.tgz(NetBSD 8.0)
earmv6hf:py27-Xlib-0.25nb1.tgz(NetBSD 9.0)
earmv6hf:py36-Xlib-0.25nb1.tgz(NetBSD 9.0)
earmv6hf:py37-Xlib-0.25nb1.tgz(NetBSD 9.0)
earmv6hf:py38-Xlib-0.25nb1.tgz(NetBSD 9.0)
earmv7hf:py27-Xlib-0.25nb1.tgz(NetBSD 8.0)
earmv7hf:py36-Xlib-0.25nb1.tgz(NetBSD 8.0)
earmv7hf:py37-Xlib-0.25nb1.tgz(NetBSD 8.0)
earmv7hf:py38-Xlib-0.25nb1.tgz(NetBSD 8.0)
earmv7hf:py27-Xlib-0.25nb1.tgz(NetBSD 9.0)
earmv7hf:py36-Xlib-0.25nb1.tgz(NetBSD 9.0)
earmv7hf:py37-Xlib-0.25nb1.tgz(NetBSD 9.0)
earmv7hf:py38-Xlib-0.25nb1.tgz(NetBSD 9.0)
i386:py26-Xlib-0.14.tgz(MirBSD 10)
i386:py27-Xlib-0.14.tgz(MirBSD 10)
i386:py27-Xlib-0.25nb1.tgz(NetBSD 7.0)
i386:py36-Xlib-0.25nb1.tgz(NetBSD 7.0)
i386:py37-Xlib-0.25nb1.tgz(NetBSD 7.0)
i386:py38-Xlib-0.25nb1.tgz(NetBSD 7.0)
i386:py27-Xlib-0.14.tgz(NetBSD 7.0)
i386:py34-Xlib-0.14.tgz(NetBSD 7.0)
i386:py36-Xlib-0.14.tgz(NetBSD 7.0)
i386:py37-Xlib-0.14.tgz(NetBSD 7.0)
i386:py27-Xlib-0.14.tgz(NetBSD 7.0)
i386:py36-Xlib-0.14.tgz(NetBSD 7.0)
i386:py37-Xlib-0.14.tgz(NetBSD 7.0)
i386:py27-Xlib-0.14.tgz(NetBSD 7.1)
i386:py34-Xlib-0.14.tgz(NetBSD 7.1)
i386:py36-Xlib-0.14.tgz(NetBSD 7.1)
i386:py37-Xlib-0.14.tgz(NetBSD 7.1)
i386:py27-Xlib-0.14.tgz(NetBSD 7.1)
i386:py36-Xlib-0.14.tgz(NetBSD 7.1)
i386:py37-Xlib-0.14.tgz(NetBSD 7.1)
i386:py27-Xlib-0.25nb1.tgz(NetBSD 7.1)
i386:py36-Xlib-0.25nb1.tgz(NetBSD 7.1)
i386:py37-Xlib-0.25nb1.tgz(NetBSD 7.1)
i386:py38-Xlib-0.25nb1.tgz(NetBSD 7.1)
i386:py27-Xlib-0.14.tgz(NetBSD 8.0)
i386:py34-Xlib-0.14.tgz(NetBSD 8.0)
i386:py35-Xlib-0.14.tgz(NetBSD 8.0)
i386:py36-Xlib-0.14.tgz(NetBSD 8.0)
i386:py37-Xlib-0.14.tgz(NetBSD 8.0)
i386:py27-Xlib-0.14.tgz(NetBSD 8.0)
i386:py36-Xlib-0.14.tgz(NetBSD 8.0)
i386:py37-Xlib-0.14.tgz(NetBSD 8.0)
i386:py27-Xlib-0.25nb1.tgz(NetBSD 8.0)
i386:py36-Xlib-0.25nb1.tgz(NetBSD 8.0)
i386:py37-Xlib-0.25nb1.tgz(NetBSD 8.0)
i386:py38-Xlib-0.25nb1.tgz(NetBSD 8.0)
i386:py27-Xlib-0.25nb1.tgz(NetBSD 9.0)
i386:py36-Xlib-0.25nb1.tgz(NetBSD 9.0)
i386:py37-Xlib-0.25nb1.tgz(NetBSD 9.0)
i386:py38-Xlib-0.25nb1.tgz(NetBSD 9.0)
i386:py26-Xlib-0.14.tgz(QNX 6.5.0)
i386:py27-Xlib-0.14.tgz(QNX 6.5.0)
i386:py31-Xlib-0.14.tgz(QNX 6.5.0)
mips64eb:py27-Xlib-0.25nb1.tgz(NetBSD 9.0)
mips64eb:py36-Xlib-0.25nb1.tgz(NetBSD 9.0)
mips64eb:py37-Xlib-0.25nb1.tgz(NetBSD 9.0)
powerpc:py27-Xlib-0.14.tgz(NetBSD 7.1)
powerpc:py34-Xlib-0.14.tgz(NetBSD 7.1)
powerpc:py35-Xlib-0.14.tgz(NetBSD 7.1)
powerpc:py36-Xlib-0.14.tgz(NetBSD 7.1)
powerpc:py37-Xlib-0.14.tgz(NetBSD 7.1)
powerpc:py27-Xlib-0.25nb1.tgz(NetBSD 8.0)
powerpc:py36-Xlib-0.25nb1.tgz(NetBSD 8.0)
powerpc:py37-Xlib-0.25nb1.tgz(NetBSD 8.0)
powerpc:py27-Xlib-0.14.tgz(NetBSD 9.0)
powerpc:py36-Xlib-0.14.tgz(NetBSD 9.0)
powerpc:py37-Xlib-0.14.tgz(NetBSD 9.0)
powerpc:py27-Xlib-0.25nb1.tgz(NetBSD 9.0)
powerpc:py36-Xlib-0.25nb1.tgz(NetBSD 9.0)
powerpc:py37-Xlib-0.25nb1.tgz(NetBSD 9.0)
sparc64:py27-Xlib-0.14.tgz(NetBSD 7.1)
sparc64:py34-Xlib-0.14.tgz(NetBSD 7.1)
sparc64:py35-Xlib-0.14.tgz(NetBSD 7.1)
sparc64:py36-Xlib-0.14.tgz(NetBSD 7.1)
sparc64:py27-Xlib-0.25nb1.tgz(NetBSD 9.0)
sparc64:py36-Xlib-0.25nb1.tgz(NetBSD 9.0)
sparc64:py37-Xlib-0.25nb1.tgz(NetBSD 9.0)
x86_64:py27-Xlib-0.25nb1.tgz(NetBSD 9.0)
x86_64:py36-Xlib-0.25nb1.tgz(NetBSD 9.0)
x86_64:py37-Xlib-0.25nb1.tgz(NetBSD 9.0)
x86_64:py38-Xlib-0.25nb1.tgz(NetBSD 9.0)
x86_64:py27-Xlib-0.25nb1.tgz(NetBSD 7.0)
x86_64:py36-Xlib-0.25nb1.tgz(NetBSD 7.0)
x86_64:py37-Xlib-0.25nb1.tgz(NetBSD 7.0)
x86_64:py38-Xlib-0.25nb1.tgz(NetBSD 7.0)
x86_64:py27-Xlib-0.14.tgz(NetBSD 7.0)
x86_64:py34-Xlib-0.14.tgz(NetBSD 7.0)
x86_64:py36-Xlib-0.14.tgz(NetBSD 7.0)
x86_64:py37-Xlib-0.14.tgz(NetBSD 7.0)
x86_64:py27-Xlib-0.14.tgz(NetBSD 7.0)
x86_64:py36-Xlib-0.14.tgz(NetBSD 7.0)
x86_64:py37-Xlib-0.14.tgz(NetBSD 7.0)
x86_64:py27-Xlib-0.25nb1.tgz(NetBSD 7.1)
x86_64:py36-Xlib-0.25nb1.tgz(NetBSD 7.1)
x86_64:py37-Xlib-0.25nb1.tgz(NetBSD 7.1)
x86_64:py38-Xlib-0.25nb1.tgz(NetBSD 7.1)
x86_64:py27-Xlib-0.14.tgz(NetBSD 7.1)
x86_64:py34-Xlib-0.14.tgz(NetBSD 7.1)
x86_64:py36-Xlib-0.14.tgz(NetBSD 7.1)
x86_64:py37-Xlib-0.14.tgz(NetBSD 7.1)
x86_64:py27-Xlib-0.14.tgz(NetBSD 7.1)
x86_64:py36-Xlib-0.14.tgz(NetBSD 7.1)
x86_64:py37-Xlib-0.14.tgz(NetBSD 7.1)
x86_64:py27-Xlib-0.25nb1.tgz(NetBSD 8.0)
x86_64:py36-Xlib-0.25nb1.tgz(NetBSD 8.0)
x86_64:py37-Xlib-0.25nb1.tgz(NetBSD 8.0)
x86_64:py38-Xlib-0.25nb1.tgz(NetBSD 8.0)
x86_64:py27-Xlib-0.14.tgz(NetBSD 8.0)
x86_64:py34-Xlib-0.14.tgz(NetBSD 8.0)
x86_64:py35-Xlib-0.14.tgz(NetBSD 8.0)
x86_64:py36-Xlib-0.14.tgz(NetBSD 8.0)
x86_64:py37-Xlib-0.14.tgz(NetBSD 8.0)
x86_64:py27-Xlib-0.14.tgz(NetBSD 8.0)
x86_64:py36-Xlib-0.14.tgz(NetBSD 8.0)
x86_64:py37-Xlib-0.14.tgz(NetBSD 8.0)
x86_64:py27-Xlib-0.25nb1.tgz(NetBSD 9.0)
x86_64:py36-Xlib-0.25nb1.tgz(NetBSD 9.0)
x86_64:py37-Xlib-0.25nb1.tgz(NetBSD 9.0)
x86_64:py38-Xlib-0.25nb1.tgz(NetBSD 9.0)
x86_64:py27-Xlib-0.25nb1.tgz(NetBSD 9.0)
x86_64:py36-Xlib-0.25nb1.tgz(NetBSD 9.0)
x86_64:py37-Xlib-0.25nb1.tgz(NetBSD 9.0)
x86_64:py38-Xlib-0.25nb1.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]