Index of /pub/pkgsrc/current/pkgsrc/x11/enlightenment

[ICO]NameLast modifiedSizeDescription

[PARENTDIR]Parent Directory  -  
[   ]DESCR2019-11-19 10:01 487  
[   ]MESSAGE.NetBSD2019-11-21 10:01 325  
[   ]Makefile2020-03-09 10:01 2.3K 
[   ]PLIST2013-06-20 10:06 29K 
[TXT]README.html2020-03-12 23:17 15K 
[   ]buildlink3.mk2020-03-09 10:01 1.1K 
[   ]distinfo2015-11-04 13:38 776  
[DIR]files/2013-06-17 10:06 -  
[DIR]patches/2013-09-03 10:06 -  

The NetBSD Packages Collection: x11/enlightenment Daemon Power

The NetBSD Packages Collection: x11/enlightenment

Brief description of the package:
Enlightenment Window Manager, Development Release

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://enlightenment.org/.

Please note that this package has a 2-clause-bsd license.

The package is located in the "x11/enlightenment" directory. The current source version of the package is "enlightenment-0.17.3nb23". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for x11/enlightenment :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ecore>=1.7.7 eet>=1.7.7 eina>=1.7.7 cwrappers>=20150314 jpeg>=8nb1 openssl>=1.1.1 jpeg>=9 openssl>=1.1.1dnb2 evas-buffer>=1.7.7 fontconfig>=2.11.91 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 evas>=1.7.7 eet>=1.7.7nb3 fontconfig>=2.13.0 evas>=1.7.7nb5 evas-software-x11>=1.7.0alpha x11-links>=1.31 osabi-NetBSD-8.1_STABLE xorgproto>=2016.1 curl>=7.12.3 heimdal>=0.4e heimdal>=0.6 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libffi>=3.3nb1 readline>=2.2 readline>=6.0 python37>=3.7.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 heimdal>=1.5.3nb22 nghttp2>=1.40.0nb2 libXScrnSaver>=1.1.2 libXcomposite>=0.3.1 Xfixes>=2.0.0 fixesproto>=3.0.0<5 Xfixes>=2.0.1nb2 xcursor>=1.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 xcursor>=1.1.1 libXdamage>=1.0.3 Xrandr>=0.99 Xrandr>=1.0.1 libXtst>=1.0.1 curl>=7.69.0nb1 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 edje>=1.7.7 evas-png>=1.7.7 png>=1.2.4 png>=1.6.0nb1 embryo>=1.7.7 lua52>=5.2.0<5.3 ecore>=1.7.7nb18 evas-png>=1.7.7nb4 evas-eet>=1.7.7 evas-jpeg>=1.7.7 edbus>=1.7.7 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 perl>=5.0 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 efreet>=1.7.7 efreet>=1.7.7nb18 eio>=1.7.7 elementary>=1.7.7 desktop-file-utils>=0.8 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 meson-[0-9]* ninja-build-[0-9]* re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.7 glib2>=2.64.0nb1 edje>=1.7.7nb23 edbus>=1.7.7nb18 evas-jpeg>=1.7.7nb4 eio>=1.7.7nb19 desktop-file-utils>=0.10nb1 imlib2>=1.1.0nb2 giflib>=5.2.1 tiff>=3.6.1 jbigkit>=2.0 tiff>=4.0.3nb5 xcb-util-keysyms>=0.3.9 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.14 xcb-proto>=1.4 evas-eet>=1.7.7nb4 elementary>=1.7.7nb21 imlib2>=1.4.5nb7 .

This package requires the following package(s) to run: ecore>=1.7.7 eet>=1.7.7 eina>=1.7.7 jpeg>=8nb1 openssl>=1.1.1 jpeg>=9 openssl>=1.1.1dnb2 evas-buffer>=1.7.7 fontconfig>=2.11.91 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 evas>=1.7.7 eet>=1.7.7nb3 fontconfig>=2.13.0 evas>=1.7.7nb5 evas-software-x11>=1.7.0alpha curl>=7.12.3 heimdal>=0.4e heimdal>=0.6 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libffi>=3.3nb1 python37>=3.7.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 heimdal>=1.5.3nb22 nghttp2>=1.40.0nb2 libXScrnSaver>=1.1.2 libXcomposite>=0.3.1 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 xcursor>=1.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 xcursor>=1.1.1 libXdamage>=1.0.3 Xrandr>=0.99 Xrandr>=1.0.1 libXtst>=1.0.1 curl>=7.69.0nb1 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 edje>=1.7.7 evas-png>=1.7.7 png>=1.2.4 png>=1.6.0nb1 embryo>=1.7.7 lua52>=5.2.0<5.3 ecore>=1.7.7nb18 evas-png>=1.7.7nb4 evas-eet>=1.7.7 evas-jpeg>=1.7.7 edbus>=1.7.7 dbus>=0.91 efreet>=1.7.7 efreet>=1.7.7nb18 eio>=1.7.7 elementary>=1.7.7 desktop-file-utils>=0.8 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.64.0nb1 edje>=1.7.7nb23 edbus>=1.7.7nb18 evas-jpeg>=1.7.7nb4 eio>=1.7.7nb19 desktop-file-utils>=0.10nb1 imlib2>=1.1.0nb2 giflib>=5.2.1 tiff>=3.6.1 jbigkit>=2.0 tiff>=4.0.3nb5 xcb-util-keysyms>=0.3.9 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 evas-eet>=1.7.7nb4 elementary>=1.7.7nb21 imlib2>=1.4.5nb7 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:

alpha:enlightenment-0.17.3nb20.tgz(NetBSD 8.0)
powerpc:enlightenment-0.17.3nb17.tgz(NetBSD 7.1)
powerpc:enlightenment-0.17.3nb16.tgz(NetBSD 7.1)
powerpc:enlightenment-0.17.3nb20.tgz(NetBSD 8.0)
sparc64:enlightenment-0.17.3nb20.tgz(NetBSD 8.0)
x86_64:enlightenment-0.17.3nb20.tgz(NetBSD 7.0)
x86_64:enlightenment-0.17.3nb17.tgz(NetBSD 7.0)
x86_64:enlightenment-0.17.3nb17.tgz(NetBSD 7.0)
x86_64:enlightenment-0.17.3nb20.tgz(NetBSD 7.0)
x86_64:enlightenment-0.17.3nb20.tgz(NetBSD 7.1)
x86_64:enlightenment-0.17.3nb17.tgz(NetBSD 7.1)
x86_64:enlightenment-0.17.3nb17.tgz(NetBSD 7.1)
x86_64:enlightenment-0.17.3nb20.tgz(NetBSD 7.1)
x86_64:enlightenment-0.17.3nb20.tgz(NetBSD 8.0)
x86_64:enlightenment-0.17.3nb17.tgz(NetBSD 8.0)
x86_64:enlightenment-0.17.3nb17.tgz(NetBSD 8.0)
x86_64:enlightenment-0.17.3nb20.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]