Daemon Power

The NetBSD Packages Collection: multimedia/pitivi

Brief description of the package:
Video editor using GStreamer/GTK

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.pitivi.org/.

Please note that this package has a gnu-lgpl-v2.1 license.

The package is located in the "multimedia/pitivi" directory. The current source version of the package is "pitivi-0.999". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for multimedia/pitivi :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py37-gobject3-[0-9]* py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 cwrappers>=20150314 libuuid>=2.18 libffi>=3.0.11 readline>=2.2 readline>=6.0 python37>=3.7.0 python37>=3.7.4 glib2>=2.48.0 pcre>=3.4nb1 pcre>=8.30nb1 meson-[0-9]* ninja-build-[0-9]* re2c>=0.11.3 glib2>=2.4.0 gobject-introspection>=1.46.0 py37-cElementTree-[0-9]* glib2>=2.58.0 libffi>=3.0.0 glib2>=2.34.0 gobject-introspection>=0.6.14nb1 py37-cairo>=1.10.0 cairo>=1.13.1 Xrender>=0.2 x11-links>=1.30 osabi-NetBSD-8.0_STABLE xorgproto>=2016.1 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.13 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 lzo>=2.01 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo>=1.16.0 cairo-gobject>=1.10.2 glib2>=2.14.0 gobject-introspection>=1.34.0 py37-cairo>=1.17.1nb1 cairo-gobject>=1.16.0 py-gobject3-common>=3.10.2 py37-gstreamer1-[0-9]* gstreamer1>=1.16.0 check>=0.9.5 gstreamer1>=1.0.0 gst-plugins1-base>=1.0.0 perl>=5.0 orc>=0.4.6 py37-matplotlib-[0-9]* py37-Pillow>=3.4 py37-olefile-[0-9]* lcms2>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 openjpeg>=2.1.0 libwebp>=0.6.0 py37-test-runner-[0-9]* py37-setuptools_scm-[0-9]* py37-test>=2.8 py37-atomicwrites>=1.0 py37-attrs>=17.4.0 py37-importlib-metadata>=0.12 py37-zipp>=0.5 py37-more-itertools-[0-9]* py37-six>=1.0.0 py37-setuptools_scm>=1.15.0 py37-more-itertools>=4.0.0 py37-packaging-[0-9]* py37-pyparsing>=2.0.2 py37-six-[0-9]* py37-pluggy>=0.12 py37-py>=1.5.0 py37-setuptools-[0-9]* py37-six>=1.10.0 py37-wcwidth-[0-9]* py37-cairo-[0-9]* py37-cycler>=0.10 py37-dateutil>=2.1 py37-six>=1.5 py37-kiwisolver>=1.0.1 py37-pyparsing>=2.2.0 py37-numpy>=1.0 g95>=0.91 py37-cython>=0.12.1 blas>=1.0nb2 libtool-fortran>=2.4.2nb9 lapack>=3.1.1 blas>=1.0nb3 py37-sqlite3-[0-9]* gst-plugins1-ogg-[0-9]* libogg>=1.1 libogg>=1.1.2nb1 gst-plugins1-theora-[0-9]* libtheora>=1.0alpha3 libvorbis>=1.0.1 libvorbis>=1.1.0nb1 libtheora>=1.0alpha3nb1 gst-plugins1-vorbis-[0-9]* gst-plugins1-gdk_pixbuf>=1.16.0 gst-plugins1-good>=1.0.3 gst-plugins1-base>=1.16.0 gdk-pixbuf2>=2.22.0 shared-mime-info>=0.15 glib2>=2.37.2 shared-mime-info>=1.0nb1 gdk-pixbuf2>=2.38.1 hicolor-icon-theme>=0.4 frei0r>=1.6.1 gst-plugins1-editing-services>=1.16.0 gstreamer1>=1.16.0nb2 gst-plugins1-bad>=1.0.3 gst-plugins1-gtk>=1.16.0 gtk3+>=3.0.0 atk>=2.15.1 glib2>=2.38.0 atk>=1.11.4 glib2>=2.57.2 gdk-pixbuf2>=2.30.0 at-spi2-atk>=2.6.1 atk>=2.33.3 glib2>=2.32.0 at-spi2-core>=2.33.2 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 libXtst>=1.0.1 at-spi2-core>=2.3.2 dbus>=1.5 atk>=2.6.0 at-spi2-core>=2.26.2 xcursor>=1.0 Xfixes>=2.0.0 fixesproto>=3.0.0<5 Xrender>=0.8 Xfixes>=2.0.1nb2 xcursor>=1.1.1 Xft2>=2.1.2nb2 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 Xrandr>=0.99 Xrandr>=1.0.1 libXcomposite>=0.3.1 pango>=1.41 Xft2>=2.1.7nb3 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.59 harfbuzz>=2.0 icu>=3.4 graphite2>=1.2 icu>=64.1 harfbuzz>=2.1.1 cairo>=1.12.10 Xft2>=2.1.7nb7 pango>=1.6.0 cairo>=1.14.0 libepoxy>=1.4 MesaLib>=3.4.2 libelf>=0.8.5 libLLVM>=7.0.1nb2 libLLVM>=4.0.0 libvdpau>=0.3 libXdamage>=1.0.3 libxshmfence>=1.2 xorg-util-macros>=1.17 libdrm>=2.4.15 libva>=2.3.0 Xrandr>=1.0.2nb3 MesaLib>=7.11.2 py37-expat>=0 libepoxy>=1.2 desktop-file-utils>=0.8 at-spi2-atk>=2.26.1nb1 xcursor>=1.1.2nb1 pango>=1.42.4nb2 hicolor-icon-theme>=0.9nb1 desktop-file-utils>=0.10nb1 gobject-introspection>=1.39.0 gtk3+>=3.24.8nb2 gst-plugins1-transcoder>=1.16.0 .

This package requires the following package(s) to run: py37-gobject3-[0-9]* py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.0.11 python37>=3.7.0 python37>=3.7.4 glib2>=2.48.0 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.4.0 gobject-introspection>=1.46.0 py37-cElementTree-[0-9]* glib2>=2.58.0 libffi>=3.0.0 glib2>=2.34.0 gobject-introspection>=0.6.14nb1 py37-cairo>=1.10.0 cairo>=1.13.1 Xrender>=0.2 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 lzo>=2.01 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo>=1.16.0 cairo-gobject>=1.10.2 glib2>=2.14.0 gobject-introspection>=1.34.0 py37-cairo>=1.17.1nb1 cairo-gobject>=1.16.0 py37-gstreamer1-[0-9]* gstreamer1>=1.16.0 check>=0.9.5 gstreamer1>=1.0.0 gst-plugins1-base>=1.0.0 perl>=5.0 orc>=0.4.6 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 py37-matplotlib-[0-9]* py37-Pillow>=3.4 py37-olefile-[0-9]* lcms2>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 openjpeg>=2.1.0 libwebp>=0.6.0 py37-cairo-[0-9]* py37-cycler>=0.10 py37-six-[0-9]* py37-dateutil>=2.1 py37-six>=1.5 py37-kiwisolver>=1.0.1 py37-setuptools-[0-9]* py37-pyparsing>=2.2.0 py37-numpy>=1.0 g95>=0.91 py37-cython>=0.12.1 blas>=1.0nb2 lapack>=3.1.1 blas>=1.0nb3 py37-sqlite3-[0-9]* gst-plugins1-ogg-[0-9]* libogg>=1.1 libogg>=1.1.2nb1 gst-plugins1-theora-[0-9]* libtheora>=1.0alpha3 libvorbis>=1.0.1 libvorbis>=1.1.0nb1 libtheora>=1.0alpha3nb1 gst-plugins1-vorbis-[0-9]* gst-plugins1-gdk_pixbuf>=1.16.0 gst-plugins1-good>=1.0.3 gst-plugins1-base>=1.16.0 gdk-pixbuf2>=2.22.0 shared-mime-info>=0.15 glib2>=2.37.2 shared-mime-info>=1.0nb1 gdk-pixbuf2>=2.38.1 hicolor-icon-theme>=0.4 frei0r>=1.6.1 gst-plugins1-editing-services>=1.16.0 gstreamer1>=1.16.0nb2 gst-plugins1-bad>=1.0.3 gst-plugins1-gtk>=1.16.0 gtk3+>=3.0.0 atk>=2.15.1 glib2>=2.38.0 atk>=1.11.4 glib2>=2.57.2 gdk-pixbuf2>=2.30.0 at-spi2-atk>=2.6.1 atk>=2.33.3 glib2>=2.32.0 at-spi2-core>=2.33.2 dbus>=0.91 libXtst>=1.0.1 at-spi2-core>=2.3.2 dbus>=1.5 atk>=2.6.0 at-spi2-core>=2.26.2 xcursor>=1.0 Xfixes>=2.0.0 Xrender>=0.8 Xfixes>=2.0.1nb2 xcursor>=1.1.1 Xft2>=2.1.2nb2 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 Xrandr>=0.99 Xrandr>=1.0.1 libXcomposite>=0.3.1 pango>=1.41 Xft2>=2.1.7nb3 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.59 harfbuzz>=2.0 icu>=3.4 graphite2>=1.2 icu>=64.1 harfbuzz>=2.1.1 cairo>=1.12.10 Xft2>=2.1.7nb7 pango>=1.6.0 cairo>=1.14.0 libepoxy>=1.4 MesaLib>=3.4.2 libelf>=0.8.5 libLLVM>=7.0.1nb2 libLLVM>=4.0.0 libvdpau>=0.3 libXdamage>=1.0.3 libxshmfence>=1.2 libdrm>=2.4.15 libva>=2.3.0 Xrandr>=1.0.2nb3 MesaLib>=7.11.2 libepoxy>=1.2 desktop-file-utils>=0.8 at-spi2-atk>=2.26.1nb1 xcursor>=1.1.2nb1 pango>=1.42.4nb2 hicolor-icon-theme>=0.9nb1 desktop-file-utils>=0.10nb1 gtk3+>=3.24.8nb2 gst-plugins1-transcoder>=1.16.0 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:pitivi-0.15.2nb14.tgz(NetBSD 8.0)
alpha:pitivi-0.15.2nb14.tgz(NetBSD 8.0)
alpha:pitivi-0.15.2nb15.tgz(NetBSD 8.0)
earm:pitivi-0.15.2nb7.tgz(NetBSD 7.0)
earm:pitivi-0.15.2nb15.tgz(NetBSD 8.0)
earmv6hf:pitivi-0.15.2nb7.tgz(NetBSD 7.0)
earmv6hf:pitivi-0.15.2nb15.tgz(NetBSD 8.0)
earmv6hf:pitivi-0.15.2nb14.tgz(NetBSD 8.0)
earmv7hf:pitivi-0.15.2nb7.tgz(NetBSD 7.0)
earmv7hf:pitivi-0.15.2nb14.tgz(NetBSD 8.0)
earmv7hf:pitivi-0.15.2nb15.tgz(NetBSD 8.0)
i386:pitivi-0.15.2nb15.tgz(NetBSD 7.0)
i386:pitivi-0.15.2nb12.tgz(NetBSD 7.0)
i386:pitivi-0.15.2nb12.tgz(NetBSD 7.0)
i386:pitivi-0.15.2nb14.tgz(NetBSD 7.0)
i386:pitivi-0.15.2nb14.tgz(NetBSD 7.0)
i386:pitivi-0.15.2nb15.tgz(NetBSD 7.1)
i386:pitivi-0.15.2nb12.tgz(NetBSD 7.1)
i386:pitivi-0.15.2nb12.tgz(NetBSD 7.1)
i386:pitivi-0.15.2nb14.tgz(NetBSD 7.1)
i386:pitivi-0.15.2nb14.tgz(NetBSD 7.1)
i386:pitivi-0.15.2nb15.tgz(NetBSD 8.0)
i386:pitivi-0.15.2nb12.tgz(NetBSD 8.0)
i386:pitivi-0.15.2nb12.tgz(NetBSD 8.0)
i386:pitivi-0.15.2nb14.tgz(NetBSD 8.0)
i386:pitivi-0.15.2nb14.tgz(NetBSD 8.0)
mips64eb:pitivi-0.15.2nb14.tgz(NetBSD 8.0)
powerpc:pitivi-0.15.2nb14.tgz(NetBSD 8.0)
powerpc:pitivi-0.15.2nb15.tgz(NetBSD 9.0)
sparc64:pitivi-0.15.2nb15.tgz(NetBSD 8.0)
sparc64:pitivi-0.15.2nb14.tgz(NetBSD 8.0)
x86_64:pitivi-0.15.2nb15.tgz(NetBSD 7.0)
x86_64:pitivi-0.15.2nb12.tgz(NetBSD 7.0)
x86_64:pitivi-0.15.2nb12.tgz(NetBSD 7.0)
x86_64:pitivi-0.15.2nb14.tgz(NetBSD 7.0)
x86_64:pitivi-0.15.2nb14.tgz(NetBSD 7.0)
x86_64:pitivi-0.15.2nb15.tgz(NetBSD 7.1)
x86_64:pitivi-0.15.2nb12.tgz(NetBSD 7.1)
x86_64:pitivi-0.15.2nb12.tgz(NetBSD 7.1)
x86_64:pitivi-0.15.2nb14.tgz(NetBSD 7.1)
x86_64:pitivi-0.15.2nb14.tgz(NetBSD 7.1)
x86_64:pitivi-0.15.2nb15.tgz(NetBSD 8.0)
x86_64:pitivi-0.15.2nb12.tgz(NetBSD 8.0)
x86_64:pitivi-0.15.2nb12.tgz(NetBSD 8.0)
x86_64:pitivi-0.15.2nb14.tgz(NetBSD 8.0)
x86_64:pitivi-0.15.2nb14.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]