Daemon Power

The NetBSD Packages Collection: inputmethod/fcitx

Brief description of the package:
Free Chinese Input Toy of X

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.fcitx-im.org/.

The package is located in the "inputmethod/fcitx" directory. The current source version of the package is "fcitx-4.2.9.6nb6". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for inputmethod/fcitx :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: bash-[0-9]* cwrappers>=20150314 gobject-introspection>=0.6.14nb1 py37-cElementTree-[0-9]* python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.0.11 readline>=2.2 readline>=6.0 python37>=3.7.0 python37>=3.7.5 py37-expat-[0-9]* glib2>=2.58.0 pcre>=3.4nb1 pcre>=8.30nb1 meson-[0-9]* ninja-build-[0-9]* re2c>=0.11.3 py37-setuptools>=0.8 glib2>=2.4.0 libffi>=3.0.0 glib2>=2.34.0 gettext-tools>=0.18.1.1nb3 gettext-lib>=0.18 cairo>=1.0.0nb2 Xrender>=0.2 x11-links>=1.31 osabi-NetBSD-8.0_STABLE xorgproto>=2016.1 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.13 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 lzo>=2.01 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 png>=1.6.0nb1 enchant2>=2 hunspell-en_US-[0-9]* hunspell>=1.2.2 perl>=5.0 hunspell>=1.7.0 unittest-cpp>=2.0.0 iso-codes>=0.50 py37-expat>=0 gtk2+>=2.4.0 py27-expat-[0-9]* shared-mime-info>=0.15 atk>=1.30.0 glib2>=2.38.0 gobject-introspection>=1.34.0 atk>=1.11.4 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 shared-mime-info>=1.0nb1 tiff>=4.0.3nb5 xcursor>=1.0 Xfixes>=2.0.0 fixesproto>=3.0.0<5 Xrender>=0.8 Xfixes>=2.0.1nb2 xcursor>=1.1.1 libXdamage>=1.0.3 Xft2>=2.1.2nb2 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 libXi>=1.3.0 libXi>=1.0.0 Xrandr>=0.99 Xrandr>=1.0.1 libXcomposite>=0.3.1 pango>=1.20.0 Xft2>=2.1.7nb3 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.59 harfbuzz>=2.0 icu>=3.4 graphite2>=1.2 icu>=64.1 harfbuzz>=2.1.1 cairo>=1.12.10 cairo-gobject>=1.10.2 cairo>=1.16.0 glib2>=2.14.0 Xft2>=2.1.7nb7 cairo-gobject>=1.16.0 pango>=1.6.0 cairo>=1.6.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 atk>=2.6.0 gdk-pixbuf2>=2.38.1 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 pango>=1.42.4nb2 python27>=2.7.1nb2 gobject-introspection>=0.9.3 gtk3+>=3.0.0 atk>=2.15.1 glib2>=2.57.2 gdk-pixbuf2>=2.30.0 at-spi2-atk>=2.6.1 atk>=2.33.3 glib2>=2.32.0 at-spi2-core>=2.33.2 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 libXtst>=1.0.1 at-spi2-core>=2.3.2 dbus>=1.5 at-spi2-core>=2.26.2 pango>=1.41 cairo>=1.14.0 libepoxy>=1.4 MesaLib>=3.4.2 libelf>=0.8.5 libLLVM>=7.0.1nb2 libLLVM>=4.0.0 libvdpau>=0.3 libxshmfence>=1.2 xorg-util-macros>=1.17 libdrm>=2.4.99 libdrm>=2.4.81 libdrm>=2.4.15 libva>=2.3.0 MesaLib>=7.11.2 libepoxy>=1.2 hicolor-icon-theme>=0.4 desktop-file-utils>=0.8 at-spi2-atk>=2.26.1nb1 hicolor-icon-theme>=0.9nb1 desktop-file-utils>=0.10nb1 gobject-introspection>=1.39.0 libxkbcommon>=0.4.0 libxcb>=1.10 xkeyboard-config>=1.9 xkbcomp-[0-9]* enchant2>=2.2.3 gtk2+>=2.24.32nb10 gtk3+>=3.24.8nb2 libxkbcommon>=0.4.0nb1 extra-cmake-modules-[0-9]* .

This package requires the following package(s) to run: bash-[0-9]* gobject-introspection>=0.6.14nb1 py37-cElementTree-[0-9]* python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.0.11 python37>=3.7.0 python37>=3.7.5 py37-expat-[0-9]* glib2>=2.58.0 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.4.0 libffi>=3.0.0 glib2>=2.34.0 gettext-tools>=0.18.1.1nb3 gettext-lib>=0.18 cairo>=1.0.0nb2 Xrender>=0.2 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 lzo>=2.01 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 png>=1.6.0nb1 enchant2>=2 hunspell-en_US-[0-9]* hunspell>=1.2.2 perl>=5.0 hunspell>=1.7.0 iso-codes>=0.50 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 gtk2+>=2.4.0 py27-expat-[0-9]* shared-mime-info>=0.15 libxml2>=2.8.0nb2 atk>=1.30.0 glib2>=2.38.0 atk>=1.11.4 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 shared-mime-info>=1.0nb1 tiff>=4.0.3nb5 xcursor>=1.0 Xfixes>=2.0.0 Xrender>=0.8 Xfixes>=2.0.1nb2 xcursor>=1.1.1 libXdamage>=1.0.3 Xft2>=2.1.2nb2 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 libXi>=1.3.0 libXi>=1.0.0 Xrandr>=0.99 Xrandr>=1.0.1 libXcomposite>=0.3.1 pango>=1.20.0 Xft2>=2.1.7nb3 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.59 harfbuzz>=2.0 icu>=3.4 graphite2>=1.2 icu>=64.1 harfbuzz>=2.1.1 cairo>=1.12.10 cairo-gobject>=1.10.2 cairo>=1.16.0 glib2>=2.14.0 Xft2>=2.1.7nb7 cairo-gobject>=1.16.0 pango>=1.6.0 cairo>=1.6.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 atk>=2.6.0 gdk-pixbuf2>=2.38.1 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 pango>=1.42.4nb2 python27>=2.7.1nb2 gtk3+>=3.0.0 atk>=2.15.1 glib2>=2.57.2 gdk-pixbuf2>=2.30.0 at-spi2-atk>=2.6.1 atk>=2.33.3 glib2>=2.32.0 at-spi2-core>=2.33.2 dbus>=0.91 libXtst>=1.0.1 gobject-introspection>=1.34.0 at-spi2-core>=2.3.2 dbus>=1.5 at-spi2-core>=2.26.2 pango>=1.41 cairo>=1.14.0 libepoxy>=1.4 MesaLib>=3.4.2 libelf>=0.8.5 libLLVM>=7.0.1nb2 libLLVM>=4.0.0 libvdpau>=0.3 libxshmfence>=1.2 libdrm>=2.4.99 libdrm>=2.4.81 libdrm>=2.4.15 libva>=2.3.0 MesaLib>=7.11.2 libepoxy>=1.2 hicolor-icon-theme>=0.4 desktop-file-utils>=0.8 at-spi2-atk>=2.26.1nb1 hicolor-icon-theme>=0.9nb1 desktop-file-utils>=0.10nb1 libxkbcommon>=0.4.0 libxcb>=1.10 enchant2>=2.2.3 gtk2+>=2.24.32nb10 gtk3+>=3.24.8nb2 libxkbcommon>=0.4.0nb1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:fcitx-4.2.9.6nb3.tgz(NetBSD 8.0)
alpha:fcitx-4.2.9.6nb3.tgz(NetBSD 8.0)
alpha:fcitx-4.2.9.6nb4.tgz(NetBSD 8.0)
earm:fcitx-4.2.9.6nb3.tgz(NetBSD 8.0)
earm:fcitx-4.2.9.6nb4.tgz(NetBSD 8.0)
earmv4:fcitx-4.2.9.6nb3.tgz(NetBSD 8.0)
earmv4:fcitx-4.2.9.6nb4.tgz(NetBSD 8.0)
earmv6hf:fcitx-4.2.9.6nb5.tgz(NetBSD 8.0)
earmv6hf:fcitx-4.2.9.6nb4.tgz(NetBSD 8.0)
earmv7hf:fcitx-4.2.9.6nb5.tgz(NetBSD 8.0)
earmv7hf:fcitx-4.2.9.6nb4.tgz(NetBSD 8.0)
i386:fcitx-3.1.1nb6.tgz(MirBSD 10)
i386:fcitx-4.2.9.6nb3.tgz(NetBSD 7.0)
i386:fcitx-4.2.9.6nb4.tgz(NetBSD 7.0)
i386:fcitx-4.2.9.6nb3.tgz(NetBSD 7.1)
i386:fcitx-4.2.9.6nb4.tgz(NetBSD 7.1)
i386:fcitx-4.2.9.6nb5.tgz(NetBSD 8.0)
i386:fcitx-4.2.9.6nb3.tgz(NetBSD 8.0)
i386:fcitx-4.2.9.6nb4.tgz(NetBSD 8.0)
mips64eb:fcitx-4.2.9.6nb4.tgz(NetBSD 8.0)
powerpc:fcitx-4.2.9.6nb4.tgz(NetBSD 8.0)
powerpc:fcitx-4.2.9.6nb5.tgz(NetBSD 8.0)
powerpc:fcitx-4.2.9.6nb4.tgz(NetBSD 9.0)
sparc64:fcitx-4.2.9.6nb4.tgz(NetBSD 8.0)
sparc64:fcitx-4.2.9.6nb5.tgz(NetBSD 8.0)
sparc:fcitx-4.2.9.6nb3.tgz(NetBSD 8.0)
sparc:fcitx-4.2.9.6nb4.tgz(NetBSD 8.0)
sparc:fcitx-4.2.9.6nb5.tgz(NetBSD 8.0)
x86_64:fcitx-4.2.9.6nb3.tgz(NetBSD 7.0)
x86_64:fcitx-4.2.9.6nb4.tgz(NetBSD 7.0)
x86_64:fcitx-4.2.9.6nb3.tgz(NetBSD 7.1)
x86_64:fcitx-4.2.9.6nb4.tgz(NetBSD 7.1)
x86_64:fcitx-4.2.9.6nb3.tgz(NetBSD 8.0)
x86_64:fcitx-4.2.9.6nb4.tgz(NetBSD 8.0)
x86_64:fcitx-4.2.9.6nb5.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]