Daemon Power

The NetBSD Packages Collection: databases/ruby-dm-postgres-adapter

Brief description of the package:
PostgreSQL Adapter for DataMapper

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/datamapper/dm-postgres-adapter.

Please note that this package has a mit license.

The package is located in the "databases/ruby-dm-postgres-adapter" directory. The current source version of the package is "ruby26-dm-postgres-adapter-1.2.0". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for databases/ruby-dm-postgres-adapter :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby26-dm-core>=1.2.0<1.3 ruby26-addressable>=2.3<3 ruby26-public_suffix>=2.0.2 ruby26-base>=2.6.6 openssl>=1.1.1 cwrappers>=20150314 libyaml>=0.1.1 openssl>=1.1.1dnb2 libyaml>=0.1.4 ruby26-do_postgres>=0.10.6<0.11 ruby26-data_objects>=0.10.16<0.11 ruby26-addressable>=2.1<3 postgresql95-client>=9.5.1 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 heimdal>=0.4e heimdal>=0.6 libxml2>=2.8.0nb2 heimdal>=1.5.3nb22 postgresql95-client>=9.5.20nb1 ruby26-dm-do-adapter>=1.2.0<1.3 ruby26-data_objects>=0.10.6<0.11 .

This package requires the following package(s) to run: ruby26-dm-core>=1.2.0<1.3 ruby26-addressable>=2.3<3 ruby26-public_suffix>=2.0.2 ruby26-base>=2.6.6 openssl>=1.1.1 libyaml>=0.1.1 openssl>=1.1.1dnb2 libyaml>=0.1.4 ruby26-do_postgres>=0.10.6<0.11 ruby26-data_objects>=0.10.16<0.11 ruby26-addressable>=2.1<3 postgresql95-client>=9.5.1 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 heimdal>=0.4e heimdal>=0.6 libxml2>=2.8.0nb2 heimdal>=1.5.3nb22 postgresql95-client>=9.5.20nb1 ruby26-dm-do-adapter>=1.2.0<1.3 ruby26-data_objects>=0.10.6<0.11 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earmv6hf:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
earmv6hf:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
earmv6hf:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
earmv6hf:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
earmv6hf:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
earmv6hf:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
earmv6hf:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
earmv6hf:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
earmv6hf:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
earmv7hf:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
earmv7hf:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
earmv7hf:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
earmv7hf:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
earmv7hf:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
earmv7hf:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
earmv7hf:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
earmv7hf:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
earmv7hf:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
i386:ruby18-dm-postgres-adapter-1.2.0.tgz(MirBSD 10)
i386:ruby193-dm-postgres-adapter-1.2.0.tgz(MirBSD 10)
i386:ruby200-dm-postgres-adapter-1.2.0.tgz(MirBSD 10)
i386:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
i386:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
i386:ruby23-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
i386:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
i386:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
i386:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
i386:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
i386:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
i386:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
i386:ruby23-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
i386:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
i386:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
i386:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
i386:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
i386:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
i386:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
i386:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
i386:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
i386:ruby23-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
i386:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
i386:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
i386:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
i386:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
i386:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
i386:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
i386:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
i386:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
i386:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
i386:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
i386:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
i386:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
i386:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
i386:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
i386:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
powerpc:ruby21-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
powerpc:ruby22-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
powerpc:ruby23-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
powerpc:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
powerpc:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
powerpc:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
powerpc:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
powerpc:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
powerpc:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
powerpc:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
powerpc:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
powerpc:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
powerpc:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
powerpc:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
sparc64:ruby22-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
sparc64:ruby23-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
sparc64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
sparc64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
sparc64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
sparc64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
sparc64:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
sparc64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
sparc64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
sparc64:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
x86_64:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
x86_64:ruby27-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
x86_64:ruby23-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.0)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
x86_64:ruby23-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 7.1)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
x86_64:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
x86_64:ruby23-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
x86_64:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
x86_64:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
x86_64:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 8.0)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
x86_64:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
x86_64:ruby24-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
x86_64:ruby25-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
x86_64:ruby26-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)
x86_64:ruby27-dm-postgres-adapter-1.2.0.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]