Index of /pub/pkgsrc/current/pkgsrc/databases/ldb

[ICO]NameLast modifiedSizeDescription

[PARENTDIR]Parent Directory  -  
[   ]DESCR2019-03-21 04:06 918  
[   ]Makefile2020-04-03 10:00 2.2K 
[   ]PLIST2020-03-18 10:00 1.0K 
[TXT]README.html2020-04-03 22:41 12K 
[   ]buildlink3.mk2019-11-11 10:00 500  
[   ]distinfo2020-04-03 10:00 671  
[   ]options.mk2020-03-18 09:29 318  
[DIR]patches/2019-11-11 10:00 -  

The NetBSD Packages Collection: databases/ldb Daemon Power

The NetBSD Packages Collection: databases/ldb

Brief description of the package:
LDAP-like embedded database

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://ldb.samba.org/.

Please note that this package has a gnu-gpl-v3 license.

The package is located in the "databases/ldb" directory. The current source version of the package is "ldb-2.1.1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for databases/ldb :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: lmdb>=0.9.14 cwrappers>=20150314 openldap-client>=2.4.6 openssl>=1.1.1 openssl>=1.1.1dnb2 tdb>=1.0.6 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.3nb1 readline>=2.2 readline>=6.0 python37>=3.7.0 libxslt-[0-9]* libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 libgcrypt>=1.6.0 libxml2>=2.8.0nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 perl>=5.0 cmocka>=1.1.3 popt>=1.7nb3 talloc>=2.1.0 tevent>=0.9.37 openldap-client>=2.4.48nb1 tdb>=1.0.6nb2 cmocka>=1.1.5 popt>=1.16nb1 .

This package requires the following package(s) to run: lmdb>=0.9.14 openldap-client>=2.4.6 openssl>=1.1.1 openssl>=1.1.1dnb2 tdb>=1.0.6 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.3nb1 python37>=3.7.0 cmocka>=1.1.3 popt>=1.7nb3 talloc>=2.1.0 tevent>=0.9.37 openldap-client>=2.4.48nb1 tdb>=1.0.6nb2 cmocka>=1.1.5 popt>=1.16nb1 .

This package supports the following build-time options:

ldap
Enable LDAP support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:

aarch64:ldb-2.0.8.tgz(NetBSD 9.0)
alpha:ldb-1.5.5.tgz(NetBSD 8.0)
alpha:ldb-2.0.8.tgz(NetBSD 9.0)
earm:ldb-2.0.8.tgz(NetBSD 9.0)
earmv4:ldb-1.5.5.tgz(NetBSD 8.0)
earmv6hf:ldb-2.0.7nb1.tgz(NetBSD 8.0)
earmv6hf:ldb-1.5.5.tgz(NetBSD 8.0)
earmv6hf:ldb-2.0.8.tgz(NetBSD 9.0)
earmv7hf:ldb-2.0.8.tgz(NetBSD 8.0)
earmv7hf:ldb-1.5.5.tgz(NetBSD 8.0)
earmv7hf:ldb-2.0.7nb1.tgz(NetBSD 9.0)
earmv7hf:ldb-2.0.8.tgz(NetBSD 9.0)
i386:ldb-2.0.8.tgz(NetBSD 7.0)
i386:ldb-1.5.4.tgz(NetBSD 7.0)
i386:ldb-1.5.5.tgz(NetBSD 7.0)
i386:ldb-1.5.5.tgz(NetBSD 7.0)
i386:ldb-1.5.4.tgz(NetBSD 7.1)
i386:ldb-1.5.5.tgz(NetBSD 7.1)
i386:ldb-1.5.5.tgz(NetBSD 7.1)
i386:ldb-2.0.8.tgz(NetBSD 7.1)
i386:ldb-1.5.4.tgz(NetBSD 8.0)
i386:ldb-1.5.5.tgz(NetBSD 8.0)
i386:ldb-1.5.5.tgz(NetBSD 8.0)
i386:ldb-2.0.8.tgz(NetBSD 8.0)
i386:ldb-2.0.8.tgz(NetBSD 9.0)
mips64eb:ldb-1.5.5.tgz(NetBSD 8.0)
mips64eb:ldb-2.0.8.tgz(NetBSD 9.0)
powerpc:ldb-2.0.7nb1.tgz(NetBSD 8.0)
powerpc:ldb-1.5.4nb2.tgz(NetBSD 9.0)
powerpc:ldb-2.0.8.tgz(NetBSD 9.0)
sparc64:ldb-1.5.5.tgz(NetBSD 8.0)
sparc64:ldb-2.0.8.tgz(NetBSD 9.0)
x86_64:ldb-2.0.8nb1.tgz(NetBSD 9.0)
x86_64:ldb-2.0.8.tgz(NetBSD 7.0)
x86_64:ldb-1.5.4.tgz(NetBSD 7.0)
x86_64:ldb-1.5.5.tgz(NetBSD 7.0)
x86_64:ldb-1.5.5.tgz(NetBSD 7.0)
x86_64:ldb-2.0.8.tgz(NetBSD 7.1)
x86_64:ldb-1.5.4.tgz(NetBSD 7.1)
x86_64:ldb-1.5.5.tgz(NetBSD 7.1)
x86_64:ldb-1.5.5.tgz(NetBSD 7.1)
x86_64:ldb-2.0.8.tgz(NetBSD 8.0)
x86_64:ldb-1.5.4.tgz(NetBSD 8.0)
x86_64:ldb-1.5.5.tgz(NetBSD 8.0)
x86_64:ldb-1.5.5.tgz(NetBSD 8.0)
x86_64:ldb-2.0.8.tgz(NetBSD 9.0)
x86_64:ldb-2.0.8nb1.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]